Virtual Port Channels
vPC Physical and Logical Topology

Virtual Port Channels

A virtual port channel (vPC) allows links that are physically connected to two different Cisco Nexus 7000 or 9000 Series devices to appear as a single port channel by a third device. The third device can be a switch, server, or any other networking device that supports port channels. A vPC can provide Layer 2 multipathing, which allows you to create redundancy and increase the bisectional bandwidth by enabling multiple parallel paths between nodes and allowing load-balancing traffic.

vPC provides the following technical benefits:

  • Allows a single device to use a port channel across two upstream devices
  • Eliminates Spanning Tree Protocol (STP) blocked ports
  • Provides a loop-free topology
  • Uses all available uplink bandwidth
  • Provides fast convergence if either the link or a device fails
  • Provides link-level resiliency
  • Ensures high availability


Lab Environment: EVE-NG

Switches OS: nxos.9.3.1

  • NXOS1: Core switch 01
  • NXOS2: Core switch 02
  • NXOS8: Access switch

No alt text provided for this image
vPC EVE-NG lab setup


Configuration?of the vPC on core Switches 01&02

NXS-SW-01# configure terminal?

Enter configuration commands, one per line. End with CNTL/Z.

NXS-SW-01(config)# feature vpc

NXS-SW-01(config)# vpc domain 100

NXS-SW-01(config-vpc-domain)# exit

NXS-SW-01(config)# interface mgmt 0

NXS-SW-01(config-if)# ip address 192.168.1.1/24

NXS-SW-01(config-if)# no shutdown

NXS-SW-01(config-if)# vrf member management

NXS-SW-01(config-if)# exit

NXS-SW-01(config)# vpc domain 100

NXS-SW-01(config-vpc-domain)# peer-keepalive destination 192.168.1.2 source 192.168.1.1 vrf management

NXS-SW-01(config-vpc-domain)# end

NXS-SW-01# show vpc peer-keepalive?

No alt text provided for this image

NXS-SW-01(config)# feature lacp?

NXS-SW-01(config)# interface ethernet 1/2-3

NXS-SW-01(config-if-range)# description *peer link*

NXS-SW-01(config-if-range)# no shutdown?

NXS-SW-01(config-if-range)# channel-group 10 mode active?

NXS-SW-01(config-if-range)# exit

NXS-SW-01(config)# interface port-channel 10

NXS-SW-01(config-if)# no shutdown?

NXS-SW-01(config-if)# description "peer link"

NXS-SW-01(config-if)# switchport?

NXS-SW-01(config-if)# switchport mode trunk?

NXS-SW-01(config-if)# vpc peer-link?

NXS-SW-01(config-if)# end

NXS-SW-01# show vpc

No alt text provided for this image

NXS-SW-02# configure terminal?

Enter configuration commands, one per line. End with CNTL/Z.

NXS-SW-02(config)# interface mgmt 0

NXS-SW-02(config-if)# ip address 192.168.1.2/24

NXS-SW-02(config-if)# no shutdown

NXS-SW-02(config-if)# vrf member management

NXS-SW-02(config-if)# exit

NXS-SW-02(config)# feature vpc

NXS-SW-02(config)# vpc domain 100

NXS-SW-02(config-vpc-domain)# peer-keepalive destination 192.168.1.1 source 192.168.1.2 vrf management

NXS-SW-02(config-vpc-domain)# end

NXS-SW-02# show vpc peer-keepalive?

No alt text provided for this image

NXS-SW-02(config)# feature lacp?

NXS-SW-02(config)# interface ethernet 1/2-3

NXS-SW-02(config-if-range)# description *peer link*

NXS-SW-02(config-if-range)# no shutdown?

NXS-SW-02(config-if-range)# channel-group 10 mode active?

NXS-SW-02(config-if-range)# exit

NXS-SW-02(config)# interface port-channel 10

NXS-SW-02(config-if)# no shutdown?

NXS-SW-02(config-if)# description "peer link"

NXS-SW-02(config-if)# switchport?

NXS-SW-02(config-if)# switchport mode trunk?

NXS-SW-02(config-if)# vpc peer-link?

NXS-SW-02(config-if)# end


Configuration of Po 20 on core switches 01&02

NXS-SW-01(config)# interface ethernet 1/4

NXS-SW-01(config-if)# no shutdown?

NXS-SW-01(config-if)# description "to access switch"

NXS-SW-01(config-if)# channel-group 20 mode active?

NXS-SW-01(config-if)# interface port-channel 20

NXS-SW-01(config-if)# no shutdown?

NXS-SW-01(config-if)# description "to access switch"

NXS-SW-01(config-if)# switchport?

NXS-SW-01(config-if)# switchport mode trunk?

NXS-SW-01(config-if)# vpc 100??

NXS-SW-01(config-if)# end


NXS-SW-02(config)# interface ethernet 1/4

NXS-SW-02(config-if)# no shutdown?

NXS-SW-02(config-if)# description "to access switch"

NXS-SW-02(config-if)# channel-group 20 mode active?

NXS-SW-02(config-if)# interface port-channel 20

NXS-SW-02(config-if)# no shutdown?

NXS-SW-02(config-if)# description "to access switch"

NXS-SW-02(config-if)# switchport?

NXS-SW-02(config-if)# switchport mode trunk?

NXS-SW-02(config-if)# vpc 100

NXS-SW-02(config-if)# end


Access switch configuration

NXS-SW-08# configure terminal?

Enter configuration commands, one per line. End with CNTL/Z.

NXS-SW-08(config)# feature lacp

NXS-SW-08(config)# interface ethernet 1/1-2

NXS-SW-08(config-if-range)# no shutdown?

NXS-SW-08(config-if-range)# description "to core switch"

NXS-SW-08(config-if-range)# channel-group 20 mode active?

NXS-SW-08(config-if-range)#

NXS-SW-08(config)# interface port-channel 20

NXS-SW-08(config-if)# no shutdown?

NXS-SW-08(config-if)# description "to core switch"

NXS-SW-08(config-if)# switchport mode trunk?


NXS-SW-08(config-if)# show port-channel summary?

No alt text provided for this image

NXS-SW-01# show vpc

No alt text provided for this image

NXS-SW-01# show vpc consistency-parameters vpc 100

No alt text provided for this image


For more details, please check below references

要查看或添加评论,请登录

Ibrahim ElSawy的更多文章