IMPLEMENTING VRF - LITE

IMPLEMENTING VRF - LITE

Part 1: Build the Network and Configure Basic Device Settings.

Configure all the Routers with the hostnames and IP address configurations as mentioned in the topology.


Part 2: Configure and Verify VRF and Interface Addressing

Enable VRF on R1.

R1(config)#ip vrf a

R1(config-vrf)#ip vrf b

R1(config-vrf)exit


Bind the interfaces of R1 to the respective VRF


R1(config)#interface gi 0/2

R1(config-if)#ip vrf forwarding a

R1(config-if)#ip address 11.11.11.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config-if)#interface gi 0/1

R1(config-if)#ip vrf forwarding b

R1(config-if)#ip address 11.11.11.1 255.255.255.0

R1(config-if)#no shutdown


Now, let’s configure R2.


R2(config)#interface gi 0/1

R2(config-if)#ip vrf forwarding a

R2(config-if)#ip address 22.22.22.1 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config-if)#interface gi 0/2

R2(config-if)#ip vrf forwarding b

R2(config-if)#ip address 22.22.22.1 255.255.255.0

R2(config-if)#no shutdown


Now, we will bring up the connectivity between R1 and R2 for which you can either add one physical link per VRF or you can create some sub-interfaces to make the communication possible. Here I am using sub-interfaces.


R1(config)#interface gi 0/0

R1(config-if)#no shutdown

R1(config-if)#exit

R1(config-if)#interface gi 0/0.1

R1(config-subif)#ip vrf forwarding a

R1(config-subif)#encapsulation dot1q 2

R1(config-subif)#ip address 12.10.1.1 255.255.255.252

R1(config-subif)#interface gi 0/0.2

R1(config-subif)#ip vrf forwarding b

R1(config-subif)#encapsulation dot1q 3

R1(config-subif)#ip address 12.10.1.1 255.255.255.252

R1(config-subif)#exit


Let’s configure R2 now.


R2(config)#interface gi 0/0

R2(config-if)#no shutdown

R2(config-if)#exit

R2(config-if)#interface gi 0/0.1

R2(config-subif)#ip vrf forwarding a

R2(config-subif)#encapsulation dot1q 2

R2(config-subif)#ip address 12.10.1.2 255.255.255.252

R2(config-subif)#interface gi 0/0.2

R2(config-subif)#ip vrf forwarding b

R2(config-subif)#encapsulation dot1q 3

R2(config-subif)#ip address 12.10.1.2 255.255.255.252

R2(config-subif)#exit


Now let’s configure OSPF to make both the sites of Customer A and Customer B communicate with each other. Let’s begin with R3


For Customer A:


R3

R3(config)router ospf 10

R3(config-router)network 11.11.11.0 0.0.0.255 area 1

R3(config-router)exit

R5

R5(config)router ospf 10

R5(config-router)network 22.22.22.0 0.0.0.255 area 1

R5(config-router)exit

R1

R1(config)router ospf 10 vrf a

R1(config-router)network 12.10.1.0 0.0.0.3 area 1

R1(config-router)network 11.11.11.0 0.0.0.255 area 1

R1(config-router)exit

R2

R2(config)router ospf 10 vrf a

R2(config-router)network 12.10.1.0 0.0.0.3 area 1

R2(config-router)network 22.22.22.0 0.0.0.255 area 1

R2(config-router)exit


Verify connectivity by pinging R5 from R3 and vice versa. If you wish to ping from R1 there you will have to specify the source as VRF A by using the command ping vrf a 22.22.22.2


For Customer B:


R4

R3(config)router ospf 20

R3(config-router)network 11.11.11.0 0.0.0.255 area 2

R3(config-router)exit

R5

R5(config)router ospf 20

R5(config-router)network 22.22.22.0 0.0.0.255 area 2

R5(config-router)exit

R1

R1(config)router ospf 20 vrf b

R1(config-router)network 12.10.1.0 0.0.0.3 area 2

R1(config-router)network 11.11.11.0 0.0.0.255 area 2

R1(config-router)exit

R2

R2(config)router ospf 20 vrf b

R2(config-router)network 12.10.1.0 0.0.0.3 area 2

R2(config-router)network 22.22.22.0 0.0.0.255 area 2

R2(config-router)exit

NEERAJ J.

Senior Network Engineer

9 个月

Great, thanks for sharing !!

回复
Somen Dey

Network Security Engineer

9 个月

Thanks for sharing

回复
Kurtney Todman

Sr. Network Engineer

9 个月

Very informative. Thank you for sharing!

回复

要查看或添加评论,请登录

Chirag Dhall的更多文章

  • How I Got My CCIE EI #68677 Part 5: Conquering the Lab Exam

    How I Got My CCIE EI #68677 Part 5: Conquering the Lab Exam

    After failing my first attempt I returned home disappointed but was sure about giving it another try. I knew I couldn’t…

    16 条评论
  • How I Got My CCIE EI #68677 Part 4: The Day I failed!

    How I Got My CCIE EI #68677 Part 4: The Day I failed!

    After spending months on traditional networking concepts, SDN, automation, and more, I was finally ready to attempt my…

    4 条评论
  • How I Got My CCIE EI #68677 Part 3: Taking the First Steps Toward CCIE

    How I Got My CCIE EI #68677 Part 3: Taking the First Steps Toward CCIE

    Having CCNP under my belt, I was ready and eligible to appear for the CCIE lab exam—but definitely not prepared. The…

    9 条评论
  • How I got my CCIE EI #68677 Part 2: From CCNA to CCNP

    How I got my CCIE EI #68677 Part 2: From CCNA to CCNP

    In my previous post, shared how my networking journey began with a spark of curiosity and determination. I took the…

    10 条评论
  • How I Got My CCIE EI #68677 Part 1: The Beginning of the Journey

    How I Got My CCIE EI #68677 Part 1: The Beginning of the Journey

    I still remember the moment I decided to step into the networking world. It was a chilly winter night, and I was…

    26 条评论
  • Understanding the Syslog Messages

    Understanding the Syslog Messages

    Syslog is undoubtedly something you have seen when working on a router or switch, even if you have never heard of it…

  • BGP Attribute and Path Selection

    BGP Attribute and Path Selection

    Usually, numerous paths connect to the same destination, which BGP routers receive. The optimal path for traffic…

    2 条评论
  • Redistribution between EIGRP and OSPF

    Redistribution between EIGRP and OSPF

    In this article, we‘ll look at an example of how to redistribute routes between EIGRP and OSPF. Configuration: Here is…

    1 条评论
  • CONFIGURING OSPF STUB AREAS

    CONFIGURING OSPF STUB AREAS

    Stub Area In this lab, we have 2 areas: Area 0 and Area 1. Let see how we can configure OSPF and enable Area 1 as Stub…

    3 条评论
  • How to Configure OSPF MD5 Authentication

    How to Configure OSPF MD5 Authentication

    Here is the topology that we will use: Here is the configuration to enable MDS authentication For MD5 authentication…

社区洞察

其他会员也浏览了