How you can use Nmon in monitoring AIX ?
Hossam Moghazy
Unix and Storage Head at Industrial Development and Workers Bank of Egypt
How you can use Nmon in monitoring AIX ?
To enable the collection of disk I/O statistics, the value iostat=true must be set.
To display the current setting for iostat, enter this command:
lsattr -E -l sys0 -a iostat
To set the value, enter this command:
chdev -l sys0 -a iostat=true
To collect 12 hours' worth of data in 2-minute intervals, run the nmon command like this:
nmon -t -f -s 120 -c 360
Run the nmon command as the root user so that the output contains the kernel settings.
While nmon is running, launch a SAS program that demonstrates the performance problems that you have reported.
Be sure to include this code at the top of the program file:
options fullstimer source source2 msglevel=i mprint notes;
options sastrace=",,,dsa" sastraceloc=saslog nostsuffix;
proc options;
run;
libname _all_ list;
/* your existing program goes here */
If the monitor is still running after the SAS program ends, do not kill the nmon monitor. Allow it to run to completion. If you expect your program to require more than 12 hours to run, increase the value of the -c parameter on the nmon command above.
The nmon command produces a .nmon file. You can zip the file to reduce its size.
Please attach the file and the complete SAS log file to your existing Technical Support track.
If it is not possible to run nmon as the root user, collect output from the following AIX commands instead:
no -L
vmo -L
ioo -L
schedo -L
nfso -L
Beginning with AIX 5.3, the nmon utility is installed by default and is integrated within the topas command.