Building Tagged VLANs on a Cisco Nexus Switch with Jumbo Frames (L2 mode not L3)

Building Tagged VLANs on a Cisco Nexus Switch with Jumbo Frames (L2 mode not L3)

Configuring VLANs and setting up jumbo frames on a Cisco Nexus switch involves several steps. In this article, we'll break down the process of building tagged VLANs, assigning VLANs to ports, and enabling jumbo frames with a 9000 MTU.

1. Setting Up Tagged VLANs

Virtual Local Area Networks (VLANs) are logical groupings of network interfaces that behave as if they are on the same physical network, even if they're not. On Cisco Nexus switches, VLANs are typically "tagged" using IEEE 802.1Q VLAN tagging.

### Steps:

1. Access the switch:

First, access the switch's command-line interface using console access or SSH.

2. Enter the Global Configuration Mode:

```

switch# configure terminal

```

3. Create the VLAN:

For example, to create VLAN 10 and VLAN 20:

```

switch(config)# vlan 10

switch(config-vlan)# name Sales_Department

switch(config-vlan)# exit

switch(config)# vlan 20

switch(config-vlan)# name HR_Department

switch(config-vlan)# exit

```

## 2. Assigning VLANs to Ports

Once VLANs are created, they can be assigned to specific interfaces or range of interfaces on the switch.

### Steps:

1. Access the desired interface:

For example, to access the interface Ethernet 1/1:

```

switch(config)# interface ethernet 1/1

```

2. Assign the VLAN using the switchport commands:

To set the interface as an access port and assign it to VLAN 10:

```

switch(config-if)# switchport mode access

switch(config-if)# switchport access vlan 10

```

If you want to set up a trunk port to carry multiple VLANs, use the following commands (for VLANs 10 and 20 in this example):

```

switch(config-if)# switchport mode trunk

switch(config-if)# switchport trunk allowed vlan 10,20

```

## 3. Setting Up Jumbo Frames (9000 MTU)

Jumbo frames are Ethernet frames that carry a payload larger than the standard 1500 bytes. Setting up jumbo frames can be beneficial in certain high-performance computing or storage environments. Here’s how you can configure jumbo frames with a 9000 MTU:

### Steps:

1. Set the system-wide jumbo MTU size:

```

switch(config)# policy-map type network-qos jumbo

switch(config-pmap-nq)# class type network-qos class-default

switch(config-pmap-c-nq)# mtu 9000

```

2. Apply the policy-map to the system:

```

switch(config)# system qos

switch(config-sys-qos)# service-policy type network-qos jumbo

```

3. Configure the MTU on an interface:

To set the MTU for a specific interface (for example, Ethernet 1/1):

```

switch(config)# interface ethernet 1/1

switch(config-if)# mtu 9216

```

Note: 9216 bytes is the entire frame size (including the Ethernet header and trailer) when using a 9000-byte MTU for the payload.

After making the necessary configurations, always remember to save the configuration to the startup configuration to ensure that changes persist after a reboot:

```

switch# copy running-config startup-config

```

Some Additional Points

Understanding VLAN Ranges


The Cisco Nexus 3000 Series switch supports VLAN numbers 1to 4094 in accordance with the IEEE 802.1Q standard. These VLANs are organized into ranges. The switch is physically limited in the number of VLANs it can support. For information about VLAN configuration limits, see the configuration limits documentation for your switch.

Important details regarding VLAN ranges:

1

Normal

Cisco default. You can use this VLAN, but you cannot modify or delete it.

2—1005

Normal

You can create, use, modify, and delete these VLANs.

1006—4094

Extended

You can create, name, and use these VLANs. You cannot change the following parameters:

  • State is always active.
  • VLAN is always enabled. You cannot shut down these VLANs.

3968—4047 and 4094

Internally allocated

These 80 VLANs, plus VLAN 4094, are allocated for internal use. You cannot create, delete, or modify any VLANs within the block reserved for internal use.

Note


VLANs 3968 to 4047 and 4094 are reserved for internal use; these VLANs cannot be changed or used.


Cisco NX-OS allocates a group of 80 VLAN numbers for those features, such as multicast and diagnostics, that need to use internal VLANs for their operation. By default, the system allocates VLANs numbered 3968 to 4047 for internal use. VLAN 4094 is also reserved for internal use by the switch.

You cannot use, modify, or delete any of the VLANs in the reserved group. You can display the VLANs that are allocated internally and their associated use.


Conclusion

Configuring tagged VLANs and setting up jumbo frames on a Cisco Nexus switch can enhance network segmentation and performance. While the steps provided here offer a foundational guide, always refer to specific Cisco Nexus model documentation and ensure you test configurations in a lab environment before deploying to a live network.

要查看或添加评论,请登录

Glenn Kelley的更多文章

社区洞察

其他会员也浏览了